読者です 読者をやめる 読者になる 読者になる

Debian EtchでCPANを1.9xにする

Etchの仕様なのかなんなのかは全然わかんないんだけど

cpan -i install Bundle::CPAN

とか

cpan> install Bundle::CPAN

とかやっても、いっこうに1.7からバージョンあがらないわけで。sudoしようがsuしようが、インストールされるディレクトリが変わったりでも、バージョンがあがらない。なんだこれ、陰謀か!

なので、無理矢理(?)CPANを1.9にする方法。

% cd .cpan/build/CPAN-1.9xxx
% perl Makefile.PL
% make
% make install

まぁこんな感じで、make installするとCPANが1.9になってくれます。

cpanたたくと、なんかいろいろ聞かれるんでそれとなくEnterを連打。で、大人の事情でcommitしてください。そうしないと、なんども初回設定する羽目になります。

cpan[1]> o conf commit

いったん、cpanはexitとかで抜けて、cpan -vとかでバージョンをチェックすると1.9になってますね。はい。

これで、やっとPlaggerインストール始められる

参考URL